Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
0.56.4.704 to 0.56.4.713 trigger @step and spawn problems
Author Message
midikit
Journeyman
*

Posts: 59
Likes Given: 9
Likes Received: 0 in 0 posts
Joined: Apr 2016
Reputation: 0



Post: #1
0.56.4.704 to 0.56.4.713 trigger @step and spawn problems
When using @step trigger on item
If stepping on a triggered item,
In 0.56.4.703 and earlier versions, the trigger is executed every second.
However, from 0.56.4.704 to 0.56.4.713 the trigger is executed only once.

And, the timer of the spawn
Up to 0.56.4.703 works fine without problems.
However, from 0.56.4.704 to 0.56.4.713, all were changed to 86399.
This is the same for all spawn time ranges.
Of course, double-clicking a spawn to force a respawn will change it to match the spawn time range value.
(This post was last modified: 12-13-2018 12:37 AM by midikit.)
12-13-2018 12:28 AM
Find all posts by this user Like Post Quote this message in a reply
Seokotov
Apprentice
*

Posts: 16
Likes Given: 2
Likes Received: 1 in 1 posts
Joined: Dec 2018
Reputation: 0

WorldAtWar

Post: #2
RE: 0.56.4.704 to 0.56.4.713 trigger @step and spawn problems
Also have many problems with memories TIMER=0 on chars.
Looks like a big timer's error.
https://github.com/Sphereserver/Source/issues/161
(This post was last modified: 12-13-2018 03:14 AM by Seokotov.)
12-13-2018 03:11 AM
Visit this user's website Find all posts by this user Like Post Quote this message in a reply
Coruja
Sphere Developer
*****

Posts: 853
Likes Given: 4
Likes Received: 200 in 164 posts
Joined: Jul 2012
Reputation: 6

Dimension Shard

Post: #3
RE: 0.56.4.704 to 0.56.4.713 trigger @step and spawn problems
I think this problem is related to sphere startup not setting TIMER value correctly on chars/items loaded from worldsave files, which already got fixed yesterday

so try using the latest build 719 to check if it's working fine
12-20-2018 06:58 AM
Find all posts by this user Like Post Quote this message in a reply
[+] 1 user Likes Coruja's post
midikit
Journeyman
*

Posts: 59
Likes Given: 9
Likes Received: 0 in 0 posts
Joined: Apr 2016
Reputation: 0



Post: #4
RE: 0.56.4.704 to 0.56.4.713 trigger @step and spawn problems
This problem works fine at 0.56.4.719
Thanks coruja Smile
12-20-2018 11:33 AM
Find all posts by this user Like Post Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

This forum uses Lukasz Tkacz MyBB addons.