Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What script pack do I use?
Author Message
fcondon
Apprentice
*

Posts: 2
Likes Given: 2
Likes Received: 0 in 0 posts
Joined: Sep 2019
Reputation: 0

Mystical Nights

Post: #1
What script pack do I use?
Just starting to get into Sphere and I am working on getting a fresh install up and running. I found 2 seperate script packs. One is the "latest script pack" found here: https://forum.spherecommunity.net/sshare.php?srt=4

the other is "Community script pack" found here: http://scripts.sphere.torfo.org/

The community one is 8+ years old but looking at the 2 has more scripts so I guess I am confused. Thanks for the help.

Bonus question: Any way do find a spawned world file or is spawning / decorating the entire world from scratch something you just need to do with sphere?

Thanks again!
09-02-2019 02:35 AM
Find all posts by this user Like Post Quote this message in a reply
golfin
Journeyman
*

Posts: 116
Likes Given: 1
Likes Received: 13 in 12 posts
Joined: Nov 2017
Reputation: 0

Drd Online

Post: #2
RE: What script pack do I use?
Comunity script pack is old, created for 56b version of sphere. But it's good for inspiration. If you are downloading the latest build, use the latest scripts.

It all depends on how much time and work you want to put into your server. Make only a copy or your own creation.
09-02-2019 02:51 AM
Visit this user's website Find all posts by this user Like Post Quote this message in a reply
[+] 1 user Likes golfin's post
fcondon
Apprentice
*

Posts: 2
Likes Given: 2
Likes Received: 0 in 0 posts
Joined: Sep 2019
Reputation: 0

Mystical Nights

Post: #3
RE: What script pack do I use?
Thanks a lot! I have a question regarding the latest script pack. It's prolly something I can ignore but errors bug me. There is a single error in the pack.

ERROR:(sphere_item_profession_barber.scp,898)Replace existing VarStr 'i_hair_afro'

I tried searching the forums and google for an answer but why is the defname i_hair_afro erroring in the default script?

lastly, how would I go about reporting an error / fix for that latest script build so it can be fixed in a later release. Thanks for the help. Sorry for newb questions. I am learning from the scripts so making sure I have no errors in what I am using to learn is beneficial.
09-02-2019 06:25 AM
Find all posts by this user Like Post Quote this message in a reply
Coruja
Sphere Developer
*****

Posts: 886
Likes Given: 5
Likes Received: 205 in 169 posts
Joined: Jul 2012
Reputation: 6

Dimension Shard

Post: #4
RE: What script pack do I use?
this community script pack is just an default script pack base with many custom scripts (made by the community) over it. But unfortunately it is no longer maintained (last update was 8 years ago) so it's not recommended use it

If you use latest 56d its recommended use the latest 56d script pack, and not the community script pack from 8 years ago. But anyway the community script pack have some custom scripts that you can pick them individually to use on your server

PS: This console error is nothing serious, to fix it you just need to open sphere_backward_compatibility.scp, search for "i_hair_afro" and remove this line
09-02-2019 03:57 PM
Find all posts by this user Like Post Quote this message in a reply
[+] 1 user Likes Coruja's post
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

This forum uses Lukasz Tkacz MyBB addons.