Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MAXping reached
Author Message
Jhobean
Journeyman
*

Posts: 60
Likes Given: 7
Likes Received: 0 in 0 posts
Joined: Jun 2019
Reputation: 0



Post: #1
MAXping reached
I don't know Why, some player got their MAXping reached. They dont connect to game..

19:55:WARNING:Connection from 142.116.209.56 rejected (MAXPINGS reached 44/35)

Is there a way to reset this counter for let them play? Or the only method is reboot the shard?

Thx

https://www.uocryptonite.com/
02-27-2020 11:12 AM
Find all posts by this user Like Post Quote this message in a reply
Coruja
Sphere Developer
*****

Posts: 970
Likes Given: 5
Likes Received: 223 in 185 posts
Joined: Jul 2012
Reputation: 7

Dimension Shard

Post: #2
RE: MAXping reached
This is handled by NetTTL (network time to live) setting on sphere.ini, if you set this value too high it will remember the connection for too long, making client reach MaxPings (max connections) faster because every time the client login or open a webpage will count as a new connection and it will remember this connection for too long

Unfortunately there's no way to reset this counter, so you must lower NetTTL value or raise MaxPings value

If you're getting these connections from sphere webpage, you can also do some HTTP caching (eg: set "Cache-Control: max-age=60" on page header) to make the client browser cache the page for X minutes, making it reload the page from cache while the cache is valid, and only do a new HTTP request to server after the cache expire
02-27-2020 01:08 PM
Find all posts by this user Like Post Quote this message in a reply
Jhobean
Journeyman
*

Posts: 60
Likes Given: 7
Likes Received: 0 in 0 posts
Joined: Jun 2019
Reputation: 0



Post: #3
RE: MAXping reached
As always, A superb respond! THX!

https://www.uocryptonite.com/
02-27-2020 01:38 PM
Find all posts by this user Like Post Quote this message in a reply
Satvet
Journeyman
*

Posts: 105
Likes Given: 32
Likes Received: 6 in 6 posts
Joined: Sep 2015
Reputation: 0



Post: #4
RE: MAXping reached
it corrects this when you write it to the console as Maxpings (IP), "Maxpings 127.0.0.1"
or, as @Coruja says, you can keep the sphere.ini "MaxPing" setting high.

Errors triggers success.
(This post was last modified: 02-27-2020 04:54 PM by Satvet.)
02-27-2020 04:16 PM
Find all posts by this user Like Post Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

This forum uses Lukasz Tkacz MyBB addons.