Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
56d / X and Windows XP
Author Message
BaLzA
Apprentice
*

Posts: 5
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: Oct 2020
Reputation: 0



Post: #1
56d / X and Windows XP
Hello everyone! I'm back on sphere finally Tongue

I'm starting the migration of my great old shard (55r4) on the new version 56d or X (32bit, lastest stable), and i'm looking for a WinXP compatible server.

My dedicated hardware is a a very low space & energy drain machine and i would like to continue using this one for the purpose:

Asus EEEBox
Intel Atom @ 1.6 GHz
Ram 1.5 Gb

OS is Windows XP Professional, SP3, 32bit, acting as server for Quake, Half-Life, Hexen, Sphere 55r4 and more. It's working flawlessy.
Visual C++ is installed too (the lastest one, 2015/17/19 and the "2010" found on spherecommunity download page)

...but...

both 56d and X won't start on the XP 32 bit
The error is "SphereSvr.exe is not a valid win32 application", on server launch.

I've checked all available documentation and can't find anything about requirements.

Anyone has any suggestion or workaround ? Cry
10-16-2020 04:40 AM
Find all posts by this user Like Post Quote this message in a reply
Ben
Sphere Developer
*****

Posts: 612
Likes Given: 2
Likes Received: 123 in 70 posts
Joined: Mar 2010
Reputation: 18

SphereCommunity

Post: #2
RE: 56d / X and Windows XP
That's a tough one as I have never heard of that one before...

AxisII's current version: 2.0.4j
AxisII SourceCode on Github
AxisII up to date changelog
10-16-2020 07:25 AM
Visit this user's website Find all posts by this user Like Post Quote this message in a reply
darksun84
Sir Spamalot
****

Posts: 1,687
Likes Given: 246
Likes Received: 162 in 151 posts
Joined: Mar 2012
Reputation: 35



Post: #3
RE: 56d / X and Windows XP
Did you download the 32bit version of sphere?
10-16-2020 11:50 PM
Find all posts by this user Like Post Quote this message in a reply
BaLzA
Apprentice
*

Posts: 5
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: Oct 2020
Reputation: 0



Post: #4
RE: 56d / X and Windows XP
(10-16-2020 11:50 PM)darksun84 Wrote:  Did you download the 32bit version of sphere?

Same error for the 32bit version of both 56d and X
(This post was last modified: 10-17-2020 09:09 AM by BaLzA.)
10-17-2020 09:09 AM
Find all posts by this user Like Post Quote this message in a reply
BaLzA
Apprentice
*

Posts: 5
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: Oct 2020
Reputation: 0



Post: #5
RE: 56d / X and Windows XP
The problem could be the Windows SDK assigned to the project, currently 8.1, that must be downgraded to 7.1 for XP compatbility.
I don't know how complex that would be for a dev to change and re-compile. But it would be welcome Smile I'm a noob on C++
(This post was last modified: 02-21-2021 09:48 AM by BaLzA.)
02-20-2021 08:54 AM
Find all posts by this user Like Post Quote this message in a reply
Kanibal
Master
**

Posts: 255
Likes Given: 6
Likes Received: 30 in 28 posts
Joined: Jun 2012
Reputation: 0



Post: #6
RE: 56d / X and Windows XP
(10-16-2020 04:40 AM)BaLzA Wrote:  Asus EEEBox
Intel Atom @ 1.6 GHz
Ram 1.5 Gb

...server for Quake, Half-Life, Hexen, Sphere 55r4 and more...

Woot

Great hardware. Try to install some Linux server instead of Win XP.

Grandmaster Localhost Admin
03-01-2021 12:36 AM
Visit this user's website Find all posts by this user Like Post Quote this message in a reply
BertonHole
Banned

Posts: 1
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: Jan 2023



Post: #7
RE: 56d / X and Windows XP
About your situation, it sounds like quite the nostalgic setup you've got going on! Your Asus EEEBox running Windows XP for all those classic games is a real throwback. As for the migration to 56d or X, it's a bit of a bummer that you're encountering that "not a valid win32 application" error. I totally get your attachment to your trusty hardware setup.
08-17-2023 12:49 AM
Find all posts by this user Like Post Quote this message in a reply
AizumYawkee
Banned

Posts: 1
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: Feb 2023



Post: #8
RE: 56d / X and Windows XP
I've heard that some newer versions of software might have compatibility issues with older operating systems like XP. The error you mentioned could be related to the 32-bit limitation of XP, but don't quote me on that. Have you considered reaching out to the devs or the community behind 56d and X? They might have insights into compatibility issues or potential workarounds. And have you ever checked out those cheap Windows 10 key options? I've heard that some people find good deals this way, maybe in the process you could use it too. Who knows what will be effective.
(This post was last modified: 08-18-2023 06:45 PM by AizumYawkee.)
08-17-2023 01:16 AM
Find all posts by this user Like Post Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

This forum uses Lukasz Tkacz MyBB addons.